summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Prior via Guix-patches via <guix-patches@gnu.org>2020-05-17 18:41:54 +0000
committerMarius Bakke <mbakke@fastmail.com>2020-05-23 21:19:13 +0200
commit1348e512375503e254f8d1f0c79a99754a94f0e8 (patch)
tree16169e8a5c04638e8105cd82f12ba3cabfdb0594
parent01e81309c01b901cf46b034152ba7c0829aa9df8 (diff)
downloadpatches-1348e512375503e254f8d1f0c79a99754a94f0e8.tar
patches-1348e512375503e254f8d1f0c79a99754a94f0e8.tar.gz
gnu: Add python-sexpdata.
* gnu/packages/python-xyz.scm (python-sexpdata): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7d8003a7fb..fb19523c17 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5768,6 +5768,25 @@ them as the version argument or in a SCM managed file.")
(define-public python2-setuptools-scm
(package-with-python2 python-setuptools-scm))
+(define-public python-sexpdata
+ (package
+ (name "python-sexpdata")
+ (version "0.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sexpdata" version))
+ (sha256
+ (base32
+ "1q4lsjyzzqrdv64l0pv4ij9nd8gqhvxqcrpxc2xpxs652sk2gj0s"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/jd-boyd/sexpdata")
+ (synopsis "S-expression parser for Python")
+ (description
+ "Sexpdata is an S-expression parser/serializer. It has load and dump
+functions like pickle, json or PyYAML module.")
+ (license license:bsd-3)))
+
(define-public python-pathlib2
(package
(name "python-pathlib2")