summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2020-05-14 12:53:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-05-14 16:48:45 +0200
commit5c7e477c6cfe89aa4dfce557ea181e5aa8ba8a05 (patch)
tree7beafcb287e8fda652c01b217f51be5cb638c87f
parent355892e1c28ea844099113536da7cc781ca1bec2 (diff)
downloadpatches-5c7e477c6cfe89aa4dfce557ea181e5aa8ba8a05.tar
patches-5c7e477c6cfe89aa4dfce557ea181e5aa8ba8a05.tar.gz
gnu: exo: Fix exo-compose-mail.
Fixes <https://issues.guix.gnu.org/issue/41244>. * gnu/packages/xfce.scm (exo)[arguments]: Add wrap-exo-compose-mail phase so it can find URI::Escape from perl-uri. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/xfce.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 4217023cf8..61b64ef553 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2019 L p R n d n <guix@lprndn.info>
;;; Copyright © 2019 Ingo Ruhnke <grumbel@gmail.com>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -213,6 +214,19 @@ to share commonly used Xfce widgets among the Xfce applications.")
(base32
"1dp5s64g6572h9zvx9js7qc72s728qsd9y7hl7hg6rwaq0cjb2gc"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; exo won't find URI::Escape otherwise
+ (add-after 'install 'wrap-exo-compose-mail
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (perl5lib (getenv "PERL5LIB")))
+ (wrap-program (string-append out "/lib/xfce4/exo/exo-compose-mail")
+ `("PERL5LIB" ":" prefix
+ (,(string-append perl5lib ":" out
+ "/lib/perl5/site_perl")))))
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)))