summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-05-13 14:47:42 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-05-13 14:47:42 +0300
commitf97ad3f85e536835cbd779c8ee2ff00d6f60fb65 (patch)
treefb92efb5ee1cce49776d8c2dc99b5ac3bfc842a3
parentd084e71c0d0f97dccf6a792e6975435de5c0bc38 (diff)
downloadpatches-f97ad3f85e536835cbd779c8ee2ff00d6f60fb65.tar
patches-f97ad3f85e536835cbd779c8ee2ff00d6f60fb65.tar.gz
gnu: kdevelop-pg-qt: Update to 2.2.1.
* gnu/packages/kde.scm (kdevelop-pg-qt): Update to 2.2.1. [source]: Download using git-fetch.
-rw-r--r--gnu/packages/kde.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 6eb02119a4..20a824e6d2 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
@@ -302,15 +302,16 @@ software (Git, Subversion, Mercurial, CVS and Bazaar).")
(define-public kdevelop-pg-qt
(package
(name "kdevelop-pg-qt")
- (version "2.2.0")
+ (version "2.2.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/KDE/kdevelop-pg-qt/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KDE/kdevelop-pg-qt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "15ja19gg6x7gww4ch12hy585x55ghbkpsiyr8fqiyjk0j6v07hh5"))))
+ (base32 "1kfab4p717acbdkcdi41d98vwch7v431gb2qi6s38hmclsf8bf8g"))))
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))
(inputs