summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-04 17:28:52 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-07 18:44:03 +0100
commita50abb3614be087dbc8bc541f27b367db4260fc5 (patch)
tree0a996ec4a476b13e356ccc4498b719430b12422c
parentced51a204e28ab64b931e01d4c00dcb32a92813f (diff)
downloadpatches-a50abb3614be087dbc8bc541f27b367db4260fc5.tar
patches-a50abb3614be087dbc8bc541f27b367db4260fc5.tar.gz
gnu: Add r-gsl.
* gnu/packages/cran.scm (r-gsl): New variable.
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c7cd95f402..899db779bf 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8467,3 +8467,24 @@ related functions.")
random number generation for (skew) stable distributions, using the
parametrizations of Nolan.")
(license license:gpl2+)))
+
+(define-public r-gsl
+ (package
+ (name "r-gsl")
+ (version "1.9-10.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gsl" version))
+ (sha256
+ (base32
+ "00isw2iha5af4s7rr8svqka9mkl9l26l8h2rnk4r7fkhh7fc97sg"))))
+ (build-system r-build-system)
+ (inputs
+ `(("gsl" ,gsl)))
+ (home-page "https://cran.r-project.org/web/packages/gsl")
+ (synopsis "Wrapper for the GNU Scientific Library")
+ (description
+ "This package provides an R wrapper for the special functions and quasi
+random number generators of the GNU Scientific Library.")
+ (license license:gpl2+)))