summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-13 16:19:05 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-13 16:19:05 +0200
commit1b35d3033d2082316343459ea4d07b9c5030cef5 (patch)
tree169275e0d3a52d588bbfa371890149ed4ebc6ba0
parente3e24d80e3f8f66b634ac2aace632afd19c602b4 (diff)
downloadpatches-1b35d3033d2082316343459ea4d07b9c5030cef5.tar
patches-1b35d3033d2082316343459ea4d07b9c5030cef5.tar.gz
gnu: Promote libyaml@0.2 to the default 'libyaml' variable.
* gnu/packages/web.scm (libyaml): Update to 0.2.4. (libyaml-0.2): Remove variable. * gnu/packages/haskell-xyz.scm (ghc-libyaml)[inputs]: Change from LIBYAML-0.2 to LIBYAML.
-rw-r--r--gnu/packages/haskell-xyz.scm2
-rw-r--r--gnu/packages/web.scm18
2 files changed, 3 insertions, 17 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 413aa0f758..29d3077755 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6628,7 +6628,7 @@ compiler versions.")
(inputs
`(("ghc-conduit" ,ghc-conduit)
("ghc-resourcet" ,ghc-resourcet)
- ("libyaml" ,libyaml-0.2)))
+ ("libyaml" ,libyaml)))
(home-page "https://github.com/snoyberg/yaml#readme")
(synopsis "Low-level, streaming YAML interface.")
(description "This package provides a Haskell wrapper over the
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 813a0dd76c..eabc3c0197 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1474,7 +1474,7 @@ hash/signatures.")
(define-public libyaml
(package
(name "libyaml")
- (version "0.1.7")
+ (version "0.2.4")
(source
(origin
(method url-fetch)
@@ -1483,7 +1483,7 @@ hash/signatures.")
version ".tar.gz"))
(sha256
(base32
- "0a87931cx5m14a1x8rbjix3nz7agrcgndf4h392vm62a4rby9240"))))
+ "0mq5wf17ifcwwxq3kbimhi53jn3fg23vcynqpzxjcz3vfjlfs2nq"))))
(build-system gnu-build-system)
(home-page "http://pyyaml.org/wiki/LibYAML")
(synopsis "YAML 1.1 parser and emitter written in C")
@@ -1491,20 +1491,6 @@ hash/signatures.")
"LibYAML is a YAML 1.1 parser and emitter written in C.")
(license license:expat)))
-(define-public libyaml-0.2
- (package
- (inherit libyaml)
- (version "0.2.4")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "http://pyyaml.org/download/libyaml/yaml-"
- version ".tar.gz"))
- (sha256
- (base32
- "0mq5wf17ifcwwxq3kbimhi53jn3fg23vcynqpzxjcz3vfjlfs2nq"))))))
-
(define-public libquvi-scripts
(package
(name "libquvi-scripts")