summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-14 00:21:41 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-14 00:21:41 +0200
commit1a044e3936ac4c1ba1575fe791bf59577b039cf9 (patch)
tree4058f7c75d866e4a80276289769b0e4130ea3ac5
parenta4d76a514fed7bdd5f6dc0fdc69942d7ad3f65f1 (diff)
downloadpatches-1a044e3936ac4c1ba1575fe791bf59577b039cf9.tar
patches-1a044e3936ac4c1ba1575fe791bf59577b039cf9.tar.gz
gnu: freehdl: Fix build failure.base-for-series-3947
Fixes <https://bugs.gnu.org/41246>. Reported by tsmish <tsymsh@gmail.com>. * gnu/packages/engineering.scm (freehdl)[source](patches): New field. [native-inputs]: Remove GCC-5.
-rw-r--r--gnu/packages/engineering.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 5674c68645..172f8481eb 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1691,7 +1692,19 @@ parallel computing platforms. It also supports serial execution.")
version ".tar.gz"))
(sha256
(base32
- "117dqs0d4pcgbzvr3jn5ppra7n7x2m6c161ywh6laa934pw7h2bz"))))
+ "117dqs0d4pcgbzvr3jn5ppra7n7x2m6c161ywh6laa934pw7h2bz"))
+ (patches
+ (list (origin
+ ;; Fix build with GCC 7. Patch taken from Arch Linux:
+ ;; https://git.archlinux.org/svntogit/community.git/tree/trunk?h=packages/freehdl
+ (method url-fetch)
+ (uri "https://git.archlinux.org/svntogit/community.git\
+/plain/trunk/build-fix.patch?h=packages/freehdl\
+&id=3bb90d64dfe6883e26083cd1fa96226d0d59175a")
+ (file-name "freehdl-c++-namespace.patch")
+ (sha256
+ (base32
+ "09df3c70rx81rnhlhry1wpdhji274nx9jb74rfprk06l4739zm08")))))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -1767,7 +1780,6 @@ parallel computing platforms. It also supports serial execution.")
("libtool" ,libtool)))
(native-inputs
`(("pkg-config-native" ,pkg-config)
- ("gcc" ,gcc-5)
("libtool-native" ,libtool)))
(home-page "http://www.freehdl.seul.org/")
(synopsis "VHDL simulator")