summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-15 18:35:21 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-15 18:35:21 +0100
commit8bd5164b4ac1ec625cdbb45ddf8c539253c75b3d (patch)
treed356d563946bd1025deb3f599e5c83355c689196
parent1f31a5e0bfd0287e5dcc6bcccd0e70474904e3cf (diff)
downloadpatches-8bd5164b4ac1ec625cdbb45ddf8c539253c75b3d.tar
patches-8bd5164b4ac1ec625cdbb45ddf8c539253c75b3d.tar.gz
gnu: python-pystache: Disable tests for python3 variant.
* gnu/packages/python.scm (python-pystache)[arguments]: Disable tests. [properties]: New field. Delay python2 variant. (python2-pystache)[arguments]: Replace 'check' phase with custom command.
-rw-r--r--gnu/packages/python.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 086890ec32..f99df753e5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2710,15 +2710,26 @@ written in pure Python.")
(base32
"0nmqsfmiw4arjxqkmf9z66ml950pcdjk6aq4gin4sywmzdjw5fzp"))))
(build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; FIXME: Python 3 tests are failing.
(home-page "http://defunkt.io/pystache/")
(synopsis "Python logic-less template engine")
(description
"Pystache is a Python implementation of the framework agnostic,
logic-free templating system Mustache.")
- (license license:expat)))
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-pystache))))))
(define-public python2-pystache
- (package-with-python2 python-pystache))
+ (package (inherit (package-with-python2
+ (strip-python2-variant python-pystache)))
+ (arguments
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "python" "test_pystache.py")))))))))
(define-public python-joblib
(package