summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-05-12 15:51:10 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-13 00:21:34 +0200
commit6f6dbf2ac17fdd16ae87a112088dcaf5d3aff328 (patch)
tree5a15469411dcfc043cba4fe459c5d3fdee32ecef
parenta1891cbffb9909d4a74faf242f28f0f2e998eb2f (diff)
downloadpatches-6f6dbf2ac17fdd16ae87a112088dcaf5d3aff328.tar
patches-6f6dbf2ac17fdd16ae87a112088dcaf5d3aff328.tar.gz
gnu: sudo: Update to 1.9.0.
* gnu/packages/admin.scm (sudo): Update to 1.9.0. [arguments]: Install example configuration to the right place Move comments to where they don't confuse me.
-rw-r--r--gnu/packages/admin.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9afd88919c..5369044300 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1277,7 +1277,7 @@ system administrator.")
(define-public sudo
(package
(name "sudo")
- (version "1.8.31p1")
+ (version "1.9.0")
(source (origin
(method url-fetch)
(uri
@@ -1287,7 +1287,7 @@ system administrator.")
version ".tar.gz")))
(sha256
(base32
- "1n0mdmgcs92af34xxsnsh1arrngymhdmwd9srjgjbk65q7xzsg67"))
+ "0p7r3cl16pjwbc48ff1gbhjw51lngrghvwblxz5lxpyzqlwi88xb"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1321,17 +1321,20 @@ system administrator.")
;; prematurely.
(("@CONFIGURE_ARGS@") "\"\""))
(substitute* (find-files "." "Makefile\\.in")
+ ;; Allow installation as non-root.
(("-o [[:graph:]]+ -g [[:graph:]]+")
- ;; Allow installation as non-root.
"")
+ ;; Don't try to create /etc/sudoers.
(("^install: (.*)install-sudoers(.*)" _ before after)
- ;; Don't try to create /etc/sudoers.
(string-append "install: " before after "\n"))
+ ;; Don't try to create /run/sudo.
(("\\$\\(DESTDIR\\)\\$\\(rundir\\)")
- ;; Don't try to create /run/sudo.
"$(TMPDIR)/dummy")
+ ;; Install example sudo{,_logsrvd}.conf to the right place.
+ (("\\$\\(DESTDIR\\)\\$\\(sysconfdir\\)")
+ "$(DESTDIR)/$(docdir)/examples")
+ ;; Don't try to create /var/db/sudo.
(("\\$\\(DESTDIR\\)\\$\\(vardir\\)")
- ;; Don't try to create /var/db/sudo.
"$(TMPDIR)/dummy"))
;; ‘Checking existing [/etc/]sudoers file for syntax errors’ is