summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-05-12 16:54:01 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-05-12 19:44:29 +0200
commit220311606a623f8d4de56b225d65cee9d6a43a69 (patch)
tree0dbed286698ca6564db1f443a8b2abf0bb98f5e2
parenteabf61651aad0d85c141f77a00cacc38fa7a92e2 (diff)
downloadpatches-220311606a623f8d4de56b225d65cee9d6a43a69.tar
patches-220311606a623f8d4de56b225d65cee9d6a43a69.tar.gz
gnu: Add r-rstatix.
* gnu/packages/cran.scm (r-rstatix): New variable.
-rw-r--r--gnu/packages/cran.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4eb6b5ee2a..b9bf9954b7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6057,6 +6057,42 @@ single layer that takes the groups for comparison and the test as arguments
and adds the annotation to the plot.")
(license license:gpl3)))
+(define-public r-rstatix
+ (package
+ (name "r-rstatix")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rstatix" version))
+ (sha256
+ (base32
+ "0ikbjmr58ah39rlwyiix50kl3yk9j7jngsvl6hh973392qdvmch6"))))
+ (properties `((upstream-name . "rstatix")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-broom" ,r-broom)
+ ("r-car" ,r-car)
+ ("r-corrplot" ,r-corrplot)
+ ("r-dplyr" ,r-dplyr)
+ ("r-magrittr" ,r-magrittr)
+ ("r-purrr" ,r-purrr)
+ ("r-rlang" ,r-rlang)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyr" ,r-tidyr)
+ ("r-tidyselect" ,r-tidyselect)))
+ (home-page "https://rpkgs.datanovia.com/rstatix/")
+ (synopsis "Pipe-friendly framework for basic statistical tests")
+ (description
+ "This package provides a simple and intuitive pipe-friendly framework,
+coherent with the @code{tidyverse} design philosophy, for performing basic
+statistical tests, including t-test, Wilcoxon test, ANOVA, Kruskal-Wallis and
+correlation analyses. The output of each test is automatically transformed
+into a tidy data frame to facilitate visualization. Additional functions are
+available for reshaping, reordering, manipulating and visualizing correlation
+matrix.")
+ (license license:gpl2)))
+
(define-public r-ggpubr
(package
(name "r-ggpubr")