summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornixo <anothersms@gmail.com>2020-05-10 10:15:11 +0200
committerLudovic Courtès <ludo@gnu.org>2020-05-12 15:32:06 +0200
commit174f5076bf8cefe00185d6f84c1a28b47f76489c (patch)
tree2419865ace823d7ad21877f11ae85b7eb0daa7ad
parent3c125ac00e8611587c2b4cd4db48e14a1e42b82c (diff)
downloadpatches-174f5076bf8cefe00185d6f84c1a28b47f76489c.tar
patches-174f5076bf8cefe00185d6f84c1a28b47f76489c.tar.gz
gnu: Add libwhich.
* gnu/packages/julia.scm (libwhich): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/julia.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index 375f933da7..2bef25277d 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -180,6 +180,45 @@
"-DLLVM_ENABLE_DUMP=ON"
"-DLLVM_LINK_LLVM_DYLIB=ON"))))))
+(define-public libwhich
+ (package
+ (name "libwhich")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vtjnash/libwhich.git")
+ ;; fixes linux-vdso.so related tests
+ (commit "87cffe10080c98e7b5786c5166e420bf1ada1d41")))
+ (sha256
+ (base32
+ "1bpa0fcqpa3ai3hm8mz0p13bf76fsq53wsfcx5qw302zh22108xr"))))
+ (arguments
+ `(#:make-flags
+ (list "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'check 'set-ld-library-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "LD_LIBRARY_PATH"
+ (string-append (assoc-ref inputs "zlib") "/lib"))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (install-file "libwhich" (string-append out "/bin")))
+ #t)))))
+ (native-inputs
+ ;; used for tests
+ `(("zlib" ,zlib)))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/vtjnash/libwhich")
+ (synopsis "Like @code{which}, for dynamic libraries")
+ (description "@code{libwhich} is like @code{which}, but for dynamic
+libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
+ (license license:expat)))
+
(define-public julia
(package
(name "julia")