summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-11 16:53:58 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-11 21:55:02 +0200
commitfc66a560efc67fabb0ed346a7b3802edbe1f1253 (patch)
tree08050acc83822d77d294d1f57047ad27f1007f5e
parenta709af585377c58f695e661c2e98adad5fcb00e6 (diff)
downloadpatches-fc66a560efc67fabb0ed346a7b3802edbe1f1253.tar
patches-fc66a560efc67fabb0ed346a7b3802edbe1f1253.tar.gz
gnu: rng-tools: Update to 6.10.
* gnu/packages/linux.scm (rng-tools): Update to 6.10. [arguments]: Add --without-rtlsdr in #:configure-flags. [inputs]: Add OPENSSL, which is no longer optional.
-rw-r--r--gnu/packages/linux.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0146427d41..290090456f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5157,7 +5157,7 @@ The collection contains a set of bandwidth and latency benchmark such as:
(package
(name "rng-tools")
(home-page "https://github.com/nhorman/rng-tools")
- (version "6.9")
+ (version "6.10")
(source (origin
(method git-fetch)
(uri (git-reference (url home-page)
@@ -5165,18 +5165,22 @@ The collection contains a set of bandwidth and latency benchmark such as:
(file-name (git-file-name name version))
(sha256
(base32
- "065jf26s8zkicb95zc9ilksjdq9gqrh5vcx3mhi6mypbnamn6w98"))))
+ "0hbml37yxs0fs69g7f2x4ixq61z0029swy99rn7ykma9mi6b7ni9"))))
(build-system gnu-build-system)
(arguments
- `(;; Avoid using OpenSSL, curl, and libxml2, reducing the closure by 166 MiB.
+ `(;; Disable support for various hardware entropy sources as they need
+ ;; dependencies that are not yet in Guix, and would significantly
+ ;; increase closure size.
#:configure-flags '("--without-nistbeacon"
- "--without-pkcs11")))
+ "--without-pkcs11"
+ "--without-rtlsdr")))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
("pkg-config" ,pkg-config)))
(inputs
- `(("libsysfs" ,sysfsutils)))
+ `(("libsysfs" ,sysfsutils)
+ ("openssl" ,openssl)))
(synopsis "Random number generator daemon")
(description
"Monitor a hardware random number generator, and supply entropy