summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-11 00:00:47 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-11 12:05:38 +0200
commitfbe17e242b539004e3aa1458c2e9ccbc635ddfb8 (patch)
tree5049effcf6cb4e271e7df0a96d0c1b7272002504
parentd58c9574b3ea91bd796e6072d2ee2ba941abb9c7 (diff)
downloadpatches-fbe17e242b539004e3aa1458c2e9ccbc635ddfb8.tar
patches-fbe17e242b539004e3aa1458c2e9ccbc635ddfb8.tar.gz
gnu: sequoia: Fix pkgconfig files.
The pkgconfig files defines the wrong prefix: It is the build directory, while it should be the installation prefix. This is caused by Makefiles replacing `PREFIX` by `$(shell pwd)`. See <https://gitlab.com/sequoia-pgp/sequoia/-/issues/502> for details. * gnu/packages/sequoia.scm (sequoia)[fix-pkgconfig-file-substitutes]: New phase.
-rw-r--r--gnu/packages/sequoia.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index 1c21c9c893..91c1dcd98d 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -148,6 +148,15 @@
(("\\ssetup.py\\s+install\\s")
" setup.py install --root=/ --single-version-externally-managed "))
#t)))
+ (add-after 'unpack 'fix-pkgconfig-file-substitutes
+ ;; preempt Makefiles replacing PREFIX by pwd
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "ffi/sequoia.pc.in"
+ (("PREFIX") out))
+ (substitute* "openpgp-ffi/sequoia-openpgp.pc.in"
+ (("PREFIX") out))
+ #t)))
(add-after 'unpack 'set-missing-env-vars
(lambda* (#:key inputs #:allow-other-keys)
;; FIXME: why do we need to set this here?