summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-04-04 06:10:24 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-11 13:46:39 +0200
commitab0471e9fc88b0bf365ffb4f6595ceaff245a21e (patch)
tree94456d5f3cb17eabe5871e06c99bd7070abf01b6
parent6d511a53cf790c10677848f797ad3c71a935c913 (diff)
downloadpatches-ab0471e9fc88b0bf365ffb4f6595ceaff245a21e.tar
patches-ab0471e9fc88b0bf365ffb4f6595ceaff245a21e.tar.gz
gnu: Add emacs-janpath-evil-numbers.
* gnu/packages/emacs-xyz.scm (emacs-janpath-evil-numbers): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5e52719f2a..9eb7fe8fad 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5603,6 +5603,32 @@ go to the second most recent edit, etc. Negative argument, @kbd{C-u -}, is
used for reverse direction.")
(license license:gpl2+)))
+(define-public emacs-janpath-evil-numbers
+ (let ((commit "d988041c1fe6e941dc8d591390750b237f71f524")
+ (version "0.5")
+ (revision "1"))
+ (package
+ (name "emacs-janpath-evil-numbers")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janpath/evil-numbers")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16zixhxxcb83m82f2cfiardfn99j3w41v6vh1qk6j9pplrlfw70v"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-evil" ,emacs-evil)))
+ (home-page "https://github.com/janpath/evil-numbers")
+ (synopsis "Increment and decrement numeric literals")
+ (description
+ "This package provides functionality to search for a number up to the
+end of a line and increment or decrement it.")
+ (license license:gpl3+))))
+
(define-public emacs-monroe
(package
(name "emacs-monroe")