summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-05-10 04:49:25 -0400
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-05-11 08:54:05 +0200
commit705a5dcb87bc742a1f9bb3c9e6501cdc435105e0 (patch)
tree078f7bafe3cc48bdc0f52a1b9f1f22415282d916
parentd8ccff833d8d6e90b92f8656c6fa3c0238e693ce (diff)
downloadpatches-705a5dcb87bc742a1f9bb3c9e6501cdc435105e0.tar
patches-705a5dcb87bc742a1f9bb3c9e6501cdc435105e0.tar.gz
gnu: xfe: Fix few more FHS directories.
* gnu/packages/disk.scm (xfe): Fix /bin and /share paths in st/config.h and src/xfedefs.h, respectively. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/disk.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 0e35ef7de1..15f08773f8 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -990,7 +990,8 @@ since they are better handled by external tools.")
(file-prog (assoc-ref inputs "file")))
(with-directory-excursion "src"
(substitute* '("FilePanel.cpp" "help.h" "SearchPanel.cpp"
- "startupnotification.cpp" "xfeutils.cpp")
+ "startupnotification.cpp" "xfeutils.cpp"
+ "../st/config.h")
(("/bin/sh" file) (string-append bash file))
(("/bin/ls" file) (string-append coreutils file))
(("/usr(/bin/du)" _ file) (string-append coreutils file))
@@ -1002,11 +1003,13 @@ since they are better handled by external tools.")
(add-after 'unpack 'patch-share-dirs
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (share (string-append out "/share")))
+ (share (string-append out "/share"))
+ (xfe (string-append share "/xfe")))
(with-directory-excursion "src"
(substitute* '("foxhacks.cpp" "help.h" "xfedefs.h"
"XFileExplorer.cpp")
- (("/(usr|opt)(/local)?/share") share)))
+ (("/(usr|opt)(/local)?/share") share)
+ (("~/.config/xfe") xfe)))
#t))))))
(native-inputs
`(("intltool" ,intltool)