summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-05-11 13:31:16 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-05-11 13:33:25 +0200
commit232f2d2634074201967a47935aa80665cc5e6bbe (patch)
tree7a588831f087db27ac9f7016ced6c8e17f318900
parentcef0e08c235d1eb9943571648ef57a59041bb292 (diff)
downloadpatches-232f2d2634074201967a47935aa80665cc5e6bbe.tar
patches-232f2d2634074201967a47935aa80665cc5e6bbe.tar.gz
gnu: Add rtl-443.
* gnu/packages/radio.scm (rtl-433): New variable.
-rw-r--r--gnu/packages/radio.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 3d393f8370..41105fb8c5 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1031,3 +1031,29 @@ It can be used to decode the ADS-B signals that planes emit to indicate
their position, altitude, speed, etc.")
(home-page "https://github.com/flightaware/dump1090")
(license license:bsd-3)))
+
+(define-public rtl-433
+ (package
+ (name "rtl-433")
+ (version "20.02")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/merbanan/rtl_433.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "11991xky9gawkragdyg27qsf7kw5bhlg7ygvf3fn7ng00x4xbh1z"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libusb" ,libusb)
+ ("rtl-sdr" ,rtl-sdr)))
+ (synopsis "Decoder for radio transmissions in ISM bands")
+ (description
+ "This is a generic data receiver, mainly for decoding radio transmissions
+from devices on the 433 MHz, 868 MHz, 315 MHz, 345 MHz and 915 MHz ISM bands.")
+ (home-page "https://github.com/merbanan/rtl_433")
+ (license license:gpl2+)))