summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-02-28 22:10:47 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-02-28 22:11:21 +0200
commitbcc65510839d1b1800e0fd93b7e4c4d8f79a754c (patch)
tree19b4c82ea2dc02b742b20c56a7363308112090dd
parentda1b30bd931563927545cd97fd47c07ca4d5f8c4 (diff)
downloadpatches-bcc65510839d1b1800e0fd93b7e4c4d8f79a754c.tar
patches-bcc65510839d1b1800e0fd93b7e4c4d8f79a754c.tar.gz
gnu: ccl: Patch absolute file-name.
* gnu/packages/lisp.scm (ccl)[arguments]: In 'pre-build add substitution for /bin/pwd.
-rw-r--r--gnu/packages/lisp.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index f05d7eec78..a506566a05 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -484,6 +484,8 @@ statistical profiler, a code coverage tool, and many other extensions.")
;; Enter the source directory for the current platform's lisp
;; kernel, and run 'make clean' to remove the precompiled one.
(lambda _
+ (substitute* "lisp-kernel/m4macros.m4"
+ (("/bin/pwd") (which "pwd")))
(chdir (string-append
"lisp-kernel/"
,(match (or (%current-target-system) (%current-system))