summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-10 22:24:38 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-10 22:24:38 +0200
commit6266a48db13f2169e3167564e143b8d4b13c0008 (patch)
tree2bbedcbfae28835bb2cd084c9e20e311bf3e468c
parent1abfb4d4e4ac9a795fbb64ae77c0052c706c2f84 (diff)
downloadpatches-6266a48db13f2169e3167564e143b8d4b13c0008.tar
patches-6266a48db13f2169e3167564e143b8d4b13c0008.tar.gz
gnu: fbreader: Fix build failure.
* gnu/packages/ebook.scm (fbreader)[native-inputs]: Distinguish GCC-5. [arguments]: Add phase 'augment-CPLUS_INCLUDE_PATH'.
-rw-r--r--gnu/packages/ebook.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 48879df1bd..4243c71673 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2017, 2019 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -297,7 +298,7 @@ designed to be used in a generic text renderer.")
("sqlite" ,sqlite)
("zlib" ,zlib)))
(native-inputs
- `(("gcc" ,gcc-5)
+ `(("gcc@5" ,gcc-5)
("pkg-config" ,pkg-config)))
(arguments
`(#:tests? #f ; No tests exist.
@@ -309,6 +310,18 @@ designed to be used in a generic text renderer.")
(assoc-ref %outputs "out") "/lib"))
#:phases
(modify-phases %standard-phases
+ (add-after 'set-paths 'augment-CPLUS_INCLUDE_PATH
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Hide the default GCC from CPLUS_INCLUDE_PATH to prevent a header
+ ;; conflict with the GCC provided in native-inputs.
+ (let ((gcc (assoc-ref inputs "gcc")))
+ (setenv "CPLUS_INCLUDE_PATH"
+ (string-join
+ (delete (string-append gcc "/include/c++")
+ (string-split (getenv "CPLUS_INCLUDE_PATH")
+ #\:))
+ ":"))
+ #t)))
(delete 'configure)
(add-after 'unpack 'fix-install-locations
(lambda* (#:key outputs #:allow-other-keys)