summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-08-06 11:38:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-03-07 13:41:28 +0100
commit61fb581fbbb12335abbebea1d8b18a4b91ced26e (patch)
treee5ba17f313703c0928d9de139453bb6471f261a0
parent1e9b19dd1fc1eeb9168d64ea9d65fe91c65cffa9 (diff)
downloadpatches-61fb581fbbb12335abbebea1d8b18a4b91ced26e.tar
patches-61fb581fbbb12335abbebea1d8b18a4b91ced26e.tar.gz
gnu: eog: Update to 3.28.2.
* gnu/packages/gnome.scm (eog): Update to 3.28.2. [build-system]: Use meson-build-system. [native-inptus]: Add gtk+:bin.
-rw-r--r--gnu/packages/gnome.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f5010aa529..a6e333da0d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3961,7 +3961,7 @@ supports playlists, song ratings, and any codecs installed through gstreamer.")
(define-public eog
(package
(name "eog")
- (version "3.26.2")
+ (version "3.28.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -3969,25 +3969,25 @@ supports playlists, song ratings, and any codecs installed through gstreamer.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1b87i31mxzayd3knn9zg00y816d093qrbyx556w8a03xz96ksgmm"))))
- (build-system glib-or-gtk-build-system)
+ "1gasrfqi7qrzdq1idh29r0n6ikkqjb6pbp7a8k5krfz5hkhyfin0"))))
+ (build-system meson-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after
- 'install 'wrap-eog
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
- (wrap-program (string-append out "/bin/eog")
- `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
- #t)))))
+ (add-after 'install 'wrap-eog
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
+ (wrap-program (string-append out "/bin/eog")
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
+ #t)))))
(propagated-inputs
`(("dconf" ,dconf)))
(native-inputs
`(("intltool" ,intltool)
("itstool" ,itstool)
("glib" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin") ; for gtk-update-icon-cache
("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)
("xmllint" ,libxml2)))