summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-10 22:16:13 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-10 22:16:13 +0200
commit1abfb4d4e4ac9a795fbb64ae77c0052c706c2f84 (patch)
tree845d1dfff660ff0349fde93f440d38e03dd65642
parent179e6c524ae4957e6ace83f72a5651767f786ca4 (diff)
downloadpatches-1abfb4d4e4ac9a795fbb64ae77c0052c706c2f84.tar
patches-1abfb4d4e4ac9a795fbb64ae77c0052c706c2f84.tar.gz
gnu: gnubik: Fix build failure.
* gnu/packages/games.scm (gnubik)[arguments]: New field.
-rw-r--r--gnu/packages/games.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b927ef4ab5..e9e408c11a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -27,7 +27,7 @@
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017, 2019 nee <nee-git@hidamari.blue>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
-;;; Copyright © 2017, 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017, 2018, 2019, 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
@@ -1252,6 +1252,16 @@ also features an attractive, 3D representation of the playing board.")
(base32
"1vlf924mq8hg93bsjj0rzvs0crc6psmlxyc6zn0fr7msnmpx6gib"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ ;; Do not attempt to run 'gtk-update-icon-cache', which is
+ ;; unnecessary and causes a needless dependency on glib.
+ (substitute* "Makefile.in"
+ (("gtk-update-icon-cache")
+ "true"))
+ #t)))))
(inputs `(("gtk+" ,gtk+-2)
("mesa" ,mesa)
("glu" ,glu)