summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-04 22:37:08 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-09 22:57:45 +0100
commitc426e61e0057947a70093cd1a6a8261d20442bc9 (patch)
tree4bd50df4542c513ff6be4940b71d2eed4547e904
parent688fe86587083c37d5e63ec9ac7c7d11fe689ace (diff)
downloadpatches-c426e61e0057947a70093cd1a6a8261d20442bc9.tar
patches-c426e61e0057947a70093cd1a6a8261d20442bc9.tar.gz
gnu: Add libass.
* gnu/packages/video.scm (libass): New variable. (ffmpeg): Add input libass.
-rw-r--r--gnu/packages/video.scm34
1 files changed, 32 insertions, 2 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index abc970451b..1928755d2b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -23,7 +23,7 @@
#:use-module (ice-9 match)
#:use-module ((guix licenses)
#:select (gpl2 gpl2+ gpl3+ lgpl2.1+ bsd-3 public-domain
- fsf-free))
+ fsf-free isc))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system cmake)
@@ -62,6 +62,7 @@
#:use-module (gnu packages sdl)
#:use-module (gnu packages ssh)
#:use-module (gnu packages texlive)
+ #:use-module (gnu packages textutils)
#:use-module (gnu packages version-control)
#:use-module (gnu packages web)
#:use-module (gnu packages xiph)
@@ -89,6 +90,34 @@ A/52 standard is used in a variety of applications, including digital
television and DVD. It is also known as AC-3.")
(license gpl2+)))
+(define-public libass
+ (package
+ (name "libass")
+ (version "0.12.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/libass/libass/releases/download/"
+ version "/libass-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1mwj2nk9g6cq6f8m1hf0ijg1299rghhy9naahqq43sc2whblb1l7"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("yasm" ,yasm)))
+ (propagated-inputs
+ `(("freetype" ,freetype)
+ ("fribidi" ,fribidi)
+ ("fontconfig" ,fontconfig)
+ ("harfbuzz" ,harfbuzz)
+ ("enca" ,enca)))
+ (home-page "https://github.com/libass/libass")
+ (synopsis "Subtitle rendering library for the ASS/SSA format")
+ (description "libass is a subtitle rendering library for the
+ASS/SSA (Advanced Substation Alpha/SubStation Alpha) subtitle format.")
+ (license isc)))
+
(define-public libcaca
(package
(name "libcaca")
@@ -177,6 +206,7 @@ SMPTE 314M.")
("opus" ,opus)
("ladspa" ,ladspa)
("lame" ,lame)
+ ("libass" ,libass)
("libbluray" ,libbluray)
("libcaca" ,libcaca)
("libcdio-paranoia" ,libcdio-paranoia)
@@ -224,7 +254,6 @@ SMPTE 314M.")
;; --enable-avisynth enable reading of AviSynth script files [no]
;; --enable-frei0r enable frei0r video filtering
;; --enable-libaacplus enable AAC+ encoding via libaacplus [no]
-;; --enable-libass enable libass subtitles rendering [no]
;; --enable-libcelt enable CELT decoding via libcelt [no]
;; --enable-libdc1394 enable IIDC-1394 grabbing using libdc1394
;; and libraw1394 [no]
@@ -269,6 +298,7 @@ SMPTE 314M.")
"--enable-fontconfig"
;; "--enable-gnutls" ; causes test failures
"--enable-ladspa"
+ "--enable-libass"
"--enable-libbluray"
"--enable-libcaca"
"--enable-libcdio"