summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2017-01-30 12:11:04 +0100
committerRoel Janssen <roel@gnu.org>2017-01-30 12:11:04 +0100
commitaa3eeeb5420524a2ba23b8484534cefe5ab181a9 (patch)
treeed2e196d4a7bd281135290af1dc78ce32c1fecc1
parent01be4f939e09fb39de18d477bb48e87004de7439 (diff)
downloadpatches-aa3eeeb5420524a2ba23b8484534cefe5ab181a9.tar
patches-aa3eeeb5420524a2ba23b8484534cefe5ab181a9.tar.gz
gnu: Add r-bsgenome-hsapiens-1000genomes-hs37d5.
* gnu/packages/bioinformatics.scm (r-bsgenome-hsapiens-1000genomes-hs37d5): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3bf352193c..c605c58ea6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6885,6 +6885,37 @@ dependencies between GO terms can be implemented and applied.")
genome data packages and support for efficient SNP representation.")
(license license:artistic2.0)))
+(define-public r-bsgenome-hsapiens-1000genomes-hs37d5
+ (package
+ (name "r-bsgenome-hsapiens-1000genomes-hs37d5")
+ (version "0.99.1")
+ (source (origin
+ (method url-fetch)
+ ;; We cannot use bioconductor-uri here because this tarball is
+ ;; located under "data/annotation/" instead of "bioc/".
+ (uri (string-append "http://www.bioconductor.org/packages/"
+ "release/data/annotation/src/contrib/"
+ "BSgenome.Hsapiens.1000genomes.hs37d5_"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1cg0g5fqmsvwyw2p9hp2yy4ilk21jkbbrnpgqvb5c36ihjwvc7sr"))))
+ (properties
+ `((upstream-name . "BSgenome.Hsapiens.1000genomes.hs37d5")))
+ (build-system r-build-system)
+ ;; As this package provides little more than a very large data file it
+ ;; doesn't make sense to build substitutes.
+ (arguments `(#:substitutable? #f))
+ (propagated-inputs
+ `(("r-bsgenome" ,r-bsgenome)))
+ (home-page
+ "http://www.bioconductor.org/packages/BSgenome.Hsapiens.1000genomes.hs37d5/")
+ (synopsis "Full genome sequences for Homo sapiens")
+ (description
+ "This package provides full genome sequences for Homo sapiens from
+1000genomes phase2 reference genome sequence (hs37d5), based on NCBI GRCh37.")
+ (license license:artistic2.0)))
+
(define-public r-impute
(package
(name "r-impute")