summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2017-02-10 12:21:08 +0100
committerDavid Craven <david@craven.ch>2017-02-10 13:39:02 +0100
commit82de2655a16dcc7a8e3b992b4afd34ec32c244a6 (patch)
tree9f060fb2709e9336236026f07a2cccba941a86ba
parent72524ae843170b7af006388ebd87fc1eb60792e5 (diff)
downloadpatches-82de2655a16dcc7a8e3b992b4afd34ec32c244a6.tar
patches-82de2655a16dcc7a8e3b992b4afd34ec32c244a6.tar.gz
gnu: git: Add GIT_EXEC_PATH search-path-specification.
Enables git plugins to be found when in they're in the system profile. * gnu/packages/version-control.scm (git)[native-search-paths]: Add GIT_EXEC_PATH. Remove git wrapper and outdated comment.
-rw-r--r--gnu/packages/version-control.scm16
1 files changed, 5 insertions, 11 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index a5e3669107..976584fa73 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -275,16 +275,7 @@ as well as the classic centralized workflow.")
(wrap-program git-sm
`("PATH" ":" prefix
(,(string-append (assoc-ref inputs "perl")
- "/bin"))))
-
- ;; Tell 'git' to look for core programs in the user's profile.
- ;; This allows user to install other outputs of this package and
- ;; have them transparently taken into account. There's a
- ;; 'GIT_EXEC_PATH' environment variable, but it's supposed to
- ;; specify a single directory, not a search path.
- (wrap-program (string-append out "/bin/git")
- `("PATH" ":" prefix
- ("$HOME/.guix-profile/libexec/git-core"))))))
+ "/bin")))))))
(add-after 'split 'install-man-pages
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -301,7 +292,10 @@ as well as the classic centralized workflow.")
(list (search-path-specification
(variable "GIT_SSL_CAINFO")
(file-type 'regular)
- (files '("etc/ssl/certs/ca-certificates.crt")))))
+ (files '("etc/ssl/certs/ca-certificates.crt")))
+ (search-path-specification
+ (variable "GIT_EXEC_PATH")
+ (files '("libexec/git-core")))))
(synopsis "Distributed version control system")
(description