summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-06-22 22:45:00 +0200
committerLudovic Courtès <ludo@gnu.org>2015-06-22 23:17:16 +0200
commit790c3717d25eda6aba542227533e7edd83efa955 (patch)
tree3e06bab1ad0cde62b34b0491d7c583ceba0ef6e7
parent0e2d0213b5bcf2fcdf5ab81dfdd965b071f30637 (diff)
downloadpatches-790c3717d25eda6aba542227533e7edd83efa955.tar
patches-790c3717d25eda6aba542227533e7edd83efa955.tar.gz
gnu: imagemagick: Do not retain reference to "doc" output.
* gnu/packages/imagemagick.scm (imagemagick)[arguments]: Use 'modify-phases'. Add 'strip-configure-xml' phase.
-rw-r--r--gnu/packages/imagemagick.scm42
1 files changed, 26 insertions, 16 deletions
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index b52237f992..4e49c60993 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -47,23 +47,33 @@
"18wbsjfccxlgsdsd6h9wvhcjrsglyi086jk4bk029ik07rh81laz"))))
(build-system gnu-build-system)
(arguments
- `(#:phases (alist-cons-before
- 'build 'pre-build
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "Makefile"
- ;; Clear the `LIBRARY_PATH' setting, which otherwise
- ;; interferes with our own use.
- (("^LIBRARY_PATH[[:blank:]]*=.*$")
- "")
+ `(#:phases (modify-phases %standard-phases
+ (add-before
+ 'build 'pre-build
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ ;; Clear the `LIBRARY_PATH' setting, which otherwise
+ ;; interferes with our own use.
+ (("^LIBRARY_PATH[[:blank:]]*=.*$")
+ "")
- ;; Since the Makefile overrides $docdir, modify it to
- ;; refer to what we want.
- (("^DOCUMENTATION_PATH[[:blank:]]*=.*$")
- (let ((doc (assoc-ref outputs "doc")))
- (string-append "DOCUMENTATION_PATH = "
- doc "/share/doc/"
- ,name "-" ,version "\n")))))
- %standard-phases)))
+ ;; Since the Makefile overrides $docdir, modify it to
+ ;; refer to what we want.
+ (("^DOCUMENTATION_PATH[[:blank:]]*=.*$")
+ (let ((doc (assoc-ref outputs "doc")))
+ (string-append "DOCUMENTATION_PATH = "
+ doc "/share/doc/"
+ ,name "-" ,version "\n"))))))
+ (add-before
+ 'configure 'strip-configure-xml
+ (lambda _
+ (substitute* "config/configure.xml.in"
+ ;; Do not record 'configure' arguments in the
+ ;; configure.xml file that gets installed: That would
+ ;; include --docdir, and thus retain a reference to the
+ ;; 'doc' output.
+ (("@CONFIGURE_ARGS@")
+ "not recorded")))))))
;; TODO: Add Jasper etc.
(inputs `(("fftw" ,fftw)
("graphviz" ,graphviz)