summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2020-05-09 21:35:43 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-05-09 21:38:33 +0200
commit6c25b00dcfb91f6839ecdecf2f570a18fb4a2727 (patch)
tree357a563c04e98e2cbaff32206cd44b3c74250752
parentb8993c36ea6585f0e09c81da170f65b27371bc32 (diff)
downloadpatches-6c25b00dcfb91f6839ecdecf2f570a18fb4a2727.tar
patches-6c25b00dcfb91f6839ecdecf2f570a18fb4a2727.tar.gz
gnu: cpplint: Update to 1.4.5.base-for-series-3891
Fix build and update to 1.4.5. * gnu/packages/cpp.scm (cpplint): Update to 1.4.5, [native-inputs]: add python-pytest, python-pytest-cov, python-pytest-runner, [arguments]: add a new 'use-later-pytest phase to remove pytest version requirement.
-rw-r--r--gnu/packages/cpp.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 371927e4c6..7227b8d516 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
@@ -363,7 +363,7 @@ tools:
(define-public cpplint
(package
(name "cpplint")
- (version "1.4.4")
+ (version "1.4.5")
(source
(origin
(method git-fetch)
@@ -373,9 +373,21 @@ tools:
(url "https://github.com/cpplint/cpplint")
(commit version)))
(sha256
- (base32 "1ns9wbizr10w7rpyp106d7ip68s5nyskr54vw9bij11sci9z0v3j"))
+ (base32 "1yzcxqx0186sh80p0ydl9z0ld51fn2cdpz9hmhrp15j53g9ira7c"))
(file-name (git-file-name name version))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'use-later-pytest
+ (lambda _
+ (substitute* "test-requirements"
+ (("pytest.*") "pytest\n"))
+ #t)))))
(build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-runner" ,python-pytest-runner)))
(home-page "https://github.com/cpplint/cpplint")
(synopsis "Static code checker for C++")
(description "@code{cpplint} is a command-line tool to check C/C++ files