summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-05-10 09:51:19 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-05-10 10:08:30 +0200
commit6528f3e0b60855b1396086935d23f32afbadb60e (patch)
tree8860e5f5ef82eae6b5cb892c1a1611a5298cd096
parentc0792d77ddc855e657ac8e98f840856a4e40c224 (diff)
downloadpatches-6528f3e0b60855b1396086935d23f32afbadb60e.tar
patches-6528f3e0b60855b1396086935d23f32afbadb60e.tar.gz
gnu: python-cheetah: Update to 3.2.4.
* gnu/packages/python-xyz.scm (python-cheetah): Update to 3.2.4. [arguments]: Add a 'fix-tests' phase.
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e953dc456a..29b3305e5b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13109,14 +13109,14 @@ possible on all supported Python versions.")
(define-public python-cheetah
(package
(name "python-cheetah")
- (version "3.1.0")
+ (version "3.2.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Cheetah3" version))
(sha256
(base32
- "1ihag9cxll6b86fc8v5lkhmr3brdbi4yiz16zpgw79yylmv8fgr9"))))
+ "0ar5dqjnqaw0c17mymd6xgd81jn9br9fblawr0x438v1571bkaya"))))
(build-system python-build-system)
(arguments
`(#:modules ((guix build utils)
@@ -13131,6 +13131,12 @@ possible on all supported Python versions.")
(("#!/usr/bin/env python")
(string-append "#!" (which "python"))))
#t))
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ (substitute* "Cheetah/Tests/ImportHooks.py"
+ (("os.path.dirname\\(__file__\\)")
+ (string-append "'" (getcwd) "/Cheetah/Tests'")))
+ #t))
(replace 'check
(lambda _
(let ((cwd (getcwd)))