summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-12-29 14:45:17 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-01-26 16:17:01 +1000
commit0832804ed582f01c4edc78d87741642da143003b (patch)
tree2dcf3752d9224f83563b82fe75b7407c47a651d7
parent78bb471f37dbe6d77bb258c5859861da7038f720 (diff)
downloadpatches-0832804ed582f01c4edc78d87741642da143003b.tar
patches-0832804ed582f01c4edc78d87741642da143003b.tar.gz
gnu: Add ruby-rubytest-cli.
* gnu/packages/ruby.scm (ruby-rubytest-cli): New variable.
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index c159e53c9f..6e34754f1b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3148,3 +3148,27 @@ case-to-class and unit-to-method test construction. This enforcement can help
focus concern on individual units of behavior.")
(home-page "http://rubyworks.github.io/lemon")
(license license:bsd-2)))
+
+(define-public ruby-rubytest-cli
+ (package
+ (name "ruby-rubytest-cli")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rubytest-cli" version))
+ (sha256
+ (base32
+ "0n7hv4k1ba4fm3i98c6ydbsqhkxgbp52mhi70ba1x3mqzfvk438p"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests
+ (propagated-inputs
+ `(("ruby-ansi" ,ruby-ansi)
+ ("ruby-rubytest" ,ruby-rubytest)))
+ (synopsis "Command-line interface for rubytest")
+ (description
+ "Rubytest CLI is a command-line interface for running tests for
+Rubytest-based test frameworks. It provides the @code{rubytest} executable.")
+ (home-page "http://rubyworks.github.io/rubytest-cli")
+ (license license:bsd-2)))