summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-04-26 22:55:29 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-04-26 22:55:29 +0300
commitdc1182751cfd62d2b91f80fed322fd1e016e4b72 (patch)
tree3eaae912adfc11682b17e37749631158a55c212d
parentd30d3e3f60df511e484adb3e459625b3251b0917 (diff)
downloadpatches-dc1182751cfd62d2b91f80fed322fd1e016e4b72.tar
patches-dc1182751cfd62d2b91f80fed322fd1e016e4b72.tar.gz
gnu: vdirsyncer: Fix building man page.
* gnu/packages/dav.scm (vdirsyncer)[arguments]: Add custom phase to patch function retrieving the version string.
-rw-r--r--gnu/packages/dav.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index 5362d3505f..1b837dfe40 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -80,6 +80,11 @@ clients.")
(if tests?
(invoke "make" "test")
#t)))
+ (add-after 'unpack 'patch-version-call
+ (lambda _
+ (substitute* "docs/conf.py"
+ (("^release.*") (string-append "release = '" ,version "'\n")))
+ #t))
(add-after 'install 'manpage
(lambda* (#:key inputs outputs #:allow-other-keys)
(invoke "make" "--directory=docs/" "man")