summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-12-16 22:28:09 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-04-18 16:49:55 -0400
commitb3492e39d791a58a54ce3e2357a619c7cd357821 (patch)
tree72e5599d350cc9f179da2e373362ea794c468db8
parentfd11f6f30423ea0988e93ed7d635fe2125fc7169 (diff)
downloadpatches-b3492e39d791a58a54ce3e2357a619c7cd357821.tar
patches-b3492e39d791a58a54ce3e2357a619c7cd357821.tar.gz
gnu: gnome-contacts: Update to 3.34.
* gnu/packages/gnome.scm (gnome-contacts): Update to 3.34. [arguments]: Add 'skip-gtk-update-icon-cache' phase. [native-inputs]: Remove gtk+:bin. (cherry picked from commit c8be9392f03522f7a98ca787d31aa2372635a762)
-rw-r--r--gnu/packages/gnome.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ef34eb6f2b..8263995dec 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1161,7 +1161,7 @@ commonly used macros.")
(define-public gnome-contacts
(package
(name "gnome-contacts")
- (version "3.32.1")
+ (version "3.34")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/gnome-contacts/"
@@ -1169,10 +1169,11 @@ commonly used macros.")
name "-" version ".tar.xz"))
(sha256
(base32
- "17g1gh8yj58cfpdx69h2szivlbjgvv982kmhnkkh0i5bwj0zs2yy"))))
+ "04igc9xvyc4kb5xf5g2missnvyvj9zv5cqxf5k4z7hb0sv42wq4r"))))
(build-system meson-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags '("-Dcheese=false")
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'generate-vapis
(lambda* (#:key inputs #:allow-other-keys)
@@ -1183,14 +1184,18 @@ commonly used macros.")
(invoke "vapigen" "--directory=vapi" "--pkg=gio-2.0"
"--library=goa-1.0"
(string-append goa "/share/gir-1.0/Goa-1.0.gir"))
+ #t))
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "build-aux/meson_post_install.py"
+ (("gtk-update-icon-cache") "true"))
#t)))))
(native-inputs
`(("glib:bin" ,glib "bin")
- ("gtk+:bin" ,gtk+ "bin")
("pkg-config" ,pkg-config)))
(inputs
- `(("cheese" ,cheese)
- ("docbook-xml" ,docbook-xml)
+ `(("docbook-xml" ,docbook-xml)
("dockbook-xsl" ,docbook-xsl)
("evolution-data-server" ,evolution-data-server)
("gettext" ,gettext-minimal)