summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-04-19 12:06:46 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2020-04-23 07:32:57 +0200
commit95c14929a7fbd3c55c5e8756953c2f257625e2b7 (patch)
tree618876fe0e767aecddc5c93b43ea4e191c283ca9
parentd64a6d267db7643edb6c9a76a830be08e147127b (diff)
downloadpatches-95c14929a7fbd3c55c5e8756953c2f257625e2b7.tar
patches-95c14929a7fbd3c55c5e8756953c2f257625e2b7.tar.gz
gnu: texinfo: Cross-build fix.
* gnu/packages/texinfo.scm (texinfo)[inputs]: Add perl. This makes the host texi2any (makeinfo) refer to the correct perl. To avoid triggering a rebuild, do this while cross-compiling only.
-rw-r--r--gnu/packages/texinfo.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index 7457d99653..70e050371d 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -68,7 +69,11 @@
"env "))
#t))))
'()))
- (inputs `(("ncurses" ,ncurses)))
+ (inputs `(("ncurses" ,ncurses)
+ ;; TODO: remove `if' in the next rebuild cycle.
+ ,@(if (%current-target-system)
+ `(("perl" ,perl))
+ '())))
;; When cross-compiling, texinfo will build some of its own binaries with
;; the native compiler. This means ncurses is needed both in both inputs
;; and native-inputs.