summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-05 16:27:55 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-05 16:27:55 +0200
commit7431553bd6a1125a132315b521031a3b0481e096 (patch)
treebf3a42626c5638b2daf78dcfa435e61a15dc0cb3
parent49279343acb25ec93cbb33649d7126b3757e228f (diff)
downloadpatches-7431553bd6a1125a132315b521031a3b0481e096.tar
patches-7431553bd6a1125a132315b521031a3b0481e096.tar.gz
gnu: libcap: Add 2.34.
* gnu/packages/linux.scm (libcap/next): New public variable.
-rw-r--r--gnu/packages/linux.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8b8945fbea..e2b3d9e6c5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2171,6 +2171,21 @@ Linux-based operating systems.")
;; License is BSD-3 or GPLv2, at the user's choice.
(license license:gpl2)))
+;; libcap 2.31 causes problems for 'fakeroot', so provide this newer variant.
+;; To be merged with libcap on the next rebuild cycle.
+(define-public libcap/next
+ (package
+ (inherit libcap)
+ (version "2.34")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kernel.org/linux/libs/security/linux-privs/"
+ "libcap2/libcap-" version ".tar.xz"))
+ (sha256
+ (base32
+ "048n1gy2p48vl9hkrr9wymfxxcpwj2aslz2bv79nhl4m2lhd9kdf"))))))
+
(define-public bridge-utils
(package
(name "bridge-utils")