summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-15 05:34:09 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-15 05:41:20 +0100
commitb2cf559772499ca96f9a678e12a50b34305b4626 (patch)
tree97b4f74909d984efb40ce19c3836cc637460bb59
parent7aed8b8a7aa7394bb2b682854998df7b86623c71 (diff)
downloadpatches-b2cf559772499ca96f9a678e12a50b34305b4626.tar
patches-b2cf559772499ca96f9a678e12a50b34305b4626.tar.gz
gnu: allegro@4: Update to 4.4.3.
* gnu/packages/game-development.scm (allegro-4): Update to 4.4.3. [source]: Remove upstreamed patch. * gnu/packages/patches/allegro4-mesa-18.2.5-and-later.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/game-development.scm8
-rw-r--r--gnu/packages/patches/allegro4-mesa-18.2.5-and-later.patch41
3 files changed, 3 insertions, 47 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 018f395eff..a2a13a5fa1 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -636,7 +636,6 @@ dist_patch_DATA = \
%D%/packages/patches/aegisub-boost68.patch \
%D%/packages/patches/agg-am_c_prototype.patch \
%D%/packages/patches/allegro-mesa-18.2.5-and-later.patch \
- %D%/packages/patches/allegro4-mesa-18.2.5-and-later.patch \
%D%/packages/patches/amule-crypto-6.patch \
%D%/packages/patches/antiword-CVE-2014-8123.patch \
%D%/packages/patches/antlr3-3_1-fix-java8-compilation.patch \
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 6b641be0ef..c2732cac81 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018 Julian Graham <joolean@gmail.com>
-;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
@@ -641,17 +641,15 @@ programming language.")
(define-public allegro-4
(package
(name "allegro")
- (version "4.4.2")
+ (version "4.4.3")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/liballeg/allegro5/"
"releases/download/" version "/allegro-"
version ".tar.gz"))
- (patches (search-patches
- "allegro4-mesa-18.2.5-and-later.patch"))
(sha256
(base32
- "1p0ghkmpc4kwij1z9rzxfv7adnpy4ayi0ifahlns1bdzgmbyf88v"))))
+ "1d5ws3ihvpa6f4qc6a6drq31pajw6bblxifr4kcxzqj9br1nw28y"))))
(build-system cmake-build-system)
(arguments
'(#:phases
diff --git a/gnu/packages/patches/allegro4-mesa-18.2.5-and-later.patch b/gnu/packages/patches/allegro4-mesa-18.2.5-and-later.patch
deleted file mode 100644
index a4944821db..0000000000
--- a/gnu/packages/patches/allegro4-mesa-18.2.5-and-later.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-Fixes compilation with Mesa >= 18.2.5.
-
-Modified from upstream to work on allegro4:
-
-https://github.com/liballeg/allegro5/commit/a40d30e21802ecf5c9382cf34af9b01bd3781e47
-
-diff --git a/addons/allegrogl/include/alleggl.h b/addons/allegrogl/include/alleggl.h
-index 0f86a6768..652dd024e 100644
---- a/addons/allegrogl/include/alleggl.h
-+++ b/addons/allegrogl/include/alleggl.h
-@@ -103,10 +103,14 @@
-
- /* HACK: Prevent both Mesa and SGI's broken headers from screwing us */
- #define __glext_h_
-+#define __gl_glext_h_
- #define __glxext_h_
-+#define __glx_glxext_h_
- #include <GL/gl.h>
- #undef __glext_h_
-+#undef __gl_glext_h_
- #undef __glxext_h_
-+#undef __glx_glxext_h_
-
- #endif /* ALLEGRO_MACOSX */
-
-diff --git a/addons/allegrogl/include/allegrogl/GLext/glx_ext_defs.h b/addons/allegrogl/include/allegrogl/GLext/glx_ext_defs.h
-index 49c502091..fba8aea5d 100644
---- a/addons/allegrogl/include/allegrogl/GLext/glx_ext_defs.h
-+++ b/addons/allegrogl/include/allegrogl/GLext/glx_ext_defs.h
-@@ -1,7 +1,9 @@
- /* HACK: Prevent both Mesa and SGI's broken headers from screwing us */
- #define __glxext_h_
-+#define __glx_glxext_h_
- #include <GL/glx.h>
- #undef __glxext_h_
-+#undef __glx_glxext_h_
-
- #ifndef GLX_VERSION_1_3
- #define _ALLEGRO_GLX_VERSION_1_3
---
-2.20.0