summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-02-15 11:02:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-02-15 11:03:26 +0100
commit9846ec0beabdc9113a37448178d62324ee4be46d (patch)
tree02247de51e5881ca3f54a9ea3a818b4990fa9b62
parenta37bdf4289e9bb533907a6ee5c4c84e68e12c5b1 (diff)
downloadpatches-9846ec0beabdc9113a37448178d62324ee4be46d.tar
patches-9846ec0beabdc9113a37448178d62324ee4be46d.tar.gz
gnu: Add python-pyfit-sne.
* gnu/packages/bioinformatics.scm (python-pyfit-sne): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d6db02188f..933b8b9adf 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14497,3 +14497,33 @@ designed for use with hybrid capture, including both whole-exome and custom
target panels, and short-read sequencing platforms such as Illumina and Ion
Torrent.")
(license license:asl2.0)))
+
+(define-public python-pyfit-sne
+ (package
+ (name "python-pyfit-sne")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KlugerLab/pyFIt-SNE.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13wh3qkzs56azmmgnxib6xfr29g7xh09sxylzjpni5j0pp0rc5qw"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)))
+ (inputs
+ `(("fftw" ,fftw)))
+ (native-inputs
+ `(("python-cython" ,python-cython)))
+ (home-page "https://github.com/KlugerLab/pyFIt-SNE")
+ (synopsis "FFT-accelerated Interpolation-based t-SNE")
+ (description
+ "t-Stochastic Neighborhood Embedding (t-SNE) is a highly successful
+method for dimensionality reduction and visualization of high dimensional
+datasets. A popular implementation of t-SNE uses the Barnes-Hut algorithm to
+approximate the gradient at each iteration of gradient descent. This package
+is a Cython wrapper for FIt-SNE.")
+ (license license:bsd-4)))