summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-21 13:08:41 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-22 00:08:26 +0200
commitf9ea3b242721fd071d033b8aa3fb36caaf3f764c (patch)
tree85646d8a2653d2278836898949bf85f028c13c45
parentce784e6c2891b585d93ab68909519752685d0e3c (diff)
downloadpatches-f9ea3b242721fd071d033b8aa3fb36caaf3f764c.tar
patches-f9ea3b242721fd071d033b8aa3fb36caaf3f764c.tar.gz
gnu: python-pyrsistent: Fix build with Pytest 5.
* gnu/packages/python-xyz.scm (python-pyrsistent)[arguments]: New field.
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0636b2b3ea..c5e9c8e6d7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2264,6 +2264,16 @@ from git information.
(base32
"1lrsjgblnapfimd0alsi1as5nz2lfqv97131l7d6anbjzq2rjri8"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ ;; The package works fine with newer Pytest and Hypothesis, but
+ ;; has pinned older versions to stay compatible with Python 2.
+ (add-before 'check 'loosen-pytest-requirement
+ (lambda _
+ (substitute* "setup.py"
+ (("pytest<5") "pytest")
+ (("hypothesis<5") "hypothesis"))
+ #t)))))
(native-inputs
`(("python-hypothesis" ,python-hypothesis)
("python-pytest" ,python-pytest)