summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-19 17:58:03 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-22 00:08:21 +0200
commitce784e6c2891b585d93ab68909519752685d0e3c (patch)
tree719af836f269656b0de3b22fa6e875f5a5fda010
parent4e0059beb1a7cf857f1575792febf995aadbef40 (diff)
downloadpatches-ce784e6c2891b585d93ab68909519752685d0e3c.tar
patches-ce784e6c2891b585d93ab68909519752685d0e3c.tar.gz
gnu: GNOME: Only include Eye of GNOME on x86_64-linux.
* gnu/packages/gnome.scm (gnome)[propagated-inputs]: Conditionally add EOG.
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fbd4c5eb96..fb8c8b9472 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7828,7 +7828,11 @@ world.")
;; GNOME-Core-Utilities
("baobab" ,baobab)
("cheese" ,cheese)
- ("eog" ,eog)
+ ;; XXX: EoG requires librsvg-next, which depends on Rust, which currently
+ ;; only works on x86_64, so exclude it on other architectures.
+ ,@(if (string-prefix? "x86_64" (%current-system))
+ `(("eog" ,eog))
+ '())
("epiphany" ,epiphany)
("evince" ,evince)
("file-roller" ,file-roller)