summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-21 13:38:58 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-22 00:08:26 +0200
commit3994b55cd64831b36f52025192580d50028448f7 (patch)
tree518000463fb62bbcc376937261383394553c827c
parentf9ea3b242721fd071d033b8aa3fb36caaf3f764c (diff)
downloadpatches-3994b55cd64831b36f52025192580d50028448f7.tar
patches-3994b55cd64831b36f52025192580d50028448f7.tar.gz
gnu: python-jedi: Fix test failure with Python 3.8.
* gnu/packages/python-xyz.scm (python-jedi)[arguments]: Add phase 'adjust-test-for-python-3.8'.
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c5e9c8e6d7..86f4552cc5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11998,6 +11998,14 @@ characters, mouse support, and auto suggestions.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-before 'check 'adjust-test-for-python-3.8
+ (lambda _
+ ;; Mimic upstream commit e7feeef64 to allow for extra output lines
+ ;; in TestSetupReadline on Python 3.8. Remove for jedi > 0.17.0.
+ (substitute* "test/test_utils.py"
+ (("assert len\\(difference\\) < 20")
+ "assert len(difference) < 22"))
+ #t))
(replace 'check
(lambda _
(setenv "HOME" "/tmp")