summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-04-15 09:42:09 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2020-04-20 08:28:50 +0200
commit4e0059beb1a7cf857f1575792febf995aadbef40 (patch)
treeee36d22a097a9b9aa65770304fa29cdff2dc279d
parentaa8db0ed0de700f6a6977b9bda2ea02b28224301 (diff)
downloadpatches-4e0059beb1a7cf857f1575792febf995aadbef40.tar
patches-4e0059beb1a7cf857f1575792febf995aadbef40.tar.gz
gnu: tar: Disable troublesome tests on the Hurd.
The sparse03.at test apparently freezes the Hurd; messages on the console: 165: listing sparse files bigger than 2^33 ext2fs: device:hd0s1: warning: bit already cleared for block 245780 ext2fs: device:hd0s1: warning: bit already cleared for block 245781 ext2fs: device:hd0s1: warning: bit already cleared for block 245782 ... ext2fs: BUG: unexpected fault on disk image ... err 0xa ext2fs: disk-pager.c:98: fault_handler: Assertion 'err' failed. the other tests just fail. * gnu/packages/base.scm (tar)[arguments]: When compiling for the Hurd, skip `sparse' and failing tests.
-rw-r--r--gnu/packages/base.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 9041d99b65..31563bab5c 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -171,7 +171,22 @@ implementation offers several extensions over the standard utility.")
(build-system gnu-build-system)
;; Note: test suite requires ~1GiB of disk space.
(arguments
- `(#:phases (modify-phases %standard-phases
+ `(,@(if (hurd-target?)
+ '(#:make-flags
+ (list (string-append
+ "TESTSUITEFLAGS= -k '"
+ "!sparse"
+ ",!renamed dirs in incrementals"
+ ",!--exclude-tag option in incremental pass"
+ ",!incremental dumps with -C"
+ ",!incremental dumps of nested directories"
+ ",!incremental restores with -C"
+ ",!concatenated incremental archives (renames)"
+ ",!renamed directory containing subdirectories"
+ ",!renamed subdirectories"
+ "'")))
+ '())
+ #:phases (modify-phases %standard-phases
(add-before 'build 'set-shell-file-name
(lambda* (#:key inputs #:allow-other-keys)
;; Do not use "/bin/sh" to run programs.