summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-04-17 12:32:44 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2020-04-19 16:18:01 +0200
commit457ded48c54ba04489cb871d3ec6bda0c59bead7 (patch)
tree5e771c3c116dea6ea1c24e59437b3c1b0077d322
parentfc179005835365c7233b2b7f5abe838404ddf869 (diff)
downloadpatches-457ded48c54ba04489cb871d3ec6bda0c59bead7.tar
patches-457ded48c54ba04489cb871d3ec6bda0c59bead7.tar.gz
gnu: git: Fix for cross-compiling to the Hurd.
* gnu/packages/version-control.scm (git)[arguments]: When cross-compiling, fix `config.mak.uname' kludge to use the host system configuration.
-rw-r--r--gnu/packages/version-control.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 88a25f04f1..7fc0244bc9 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -253,9 +253,17 @@ as well as the classic centralized workflow.")
,@%gnu-build-system-modules)
#:phases
(modify-phases %standard-phases
- ;; We do not have bash-for-tests when cross-compiling.
,@(if (%current-target-system)
- '()
+ ;; The git build system assumes build == host
+ `((add-after 'unpack 'use-host-uname_S
+ (lambda _
+ (substitute* "config.mak.uname"
+ (("uname_S := .*" all)
+ (if (equal? ,(%current-target-system) "i586-pc-gnu")
+ "uname_S := GNU\n"
+ all)))
+ #t)))
+ ;; We do not have bash-for-tests when cross-compiling.
`((add-after 'unpack 'modify-PATH
(lambda* (#:key inputs #:allow-other-keys)
(let ((path (string-split (getenv "PATH") #\:))