summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-19 15:52:35 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-19 15:52:35 +0200
commit0e907e27ed0066a0be56a7ace8a5fca6a36376eb (patch)
tree571ed0bff893b1fba5d91e3899e6e48b3ad61be0
parent9a749af4677ef3d63cd4cd46c05045b53cb64dc1 (diff)
downloadpatches-0e907e27ed0066a0be56a7ace8a5fca6a36376eb.tar
patches-0e907e27ed0066a0be56a7ace8a5fca6a36376eb.tar.gz
gnu: boost-static: Adjust for Python 3 migration in Boost.
* gnu/packages/boost.scm (boost-static)[arguments]: Adjust libboost_python27.a file name to take the Python 3 counterpart in the provide_libboost_python phase.
-rw-r--r--gnu/packages/boost.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index afdbdbd15b..c3fc144cec 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -210,10 +210,18 @@ across a broad spectrum of applications.")
((#:phases phases)
`(modify-phases ,phases
(replace 'provide-libboost_python
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (python-version (python-version
+ (assoc-ref inputs "python")))
+ (libboost_pythonNN.a
+ (string-append "libboost_python"
+ (string-join (string-split
+ python-version #\.)
+ "")
+ ".a")))
(with-directory-excursion (string-append out "/lib")
- (symlink "libboost_python27.a" "libboost_python.a"))
+ (symlink libboost_pythonNN.a "libboost_python.a"))
#t)))))))))
(define-public boost-1.69