summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-27 19:47:23 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-01 22:06:33 +0200
commite66bbd4201566cdc388f9b02d59da17beb8eb47d (patch)
treed021cd0deb16cb53dc345bef4d0029516f6b16e6
parentdb7c73f53a0b2470392e29d818ed4ea17ddcc505 (diff)
downloadpatches-e66bbd4201566cdc388f9b02d59da17beb8eb47d.tar
patches-e66bbd4201566cdc388f9b02d59da17beb8eb47d.tar.gz
gnu: %guile-static-stripped: Rewrite in terms of 'make-guile-static-stripped'.
The derivation changes slightly, but the end result is bit-identical. * gnu/packages/make-bootstrap.scm (make-guile-static-stripped): New procedure. (%guile-static-stripped): Adjust accordingly.
-rw-r--r--gnu/packages/make-bootstrap.scm28
1 files changed, 16 insertions, 12 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index f4d7fd6a2a..d336818299 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -745,30 +745,30 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
"guile-default-utf8.patch"
"guile-linux-syscalls.patch")))
-(define %guile-static-stripped
- ;; A stripped static Guile binary, for use during bootstrap.
- (package (inherit %guile-static)
- (name "guile-static-stripped")
+(define* (make-guile-static-stripped static-guile)
+ (package
+ (inherit static-guile)
+ (name (string-append (package-name static-guile) "-stripped"))
(build-system trivial-build-system)
(arguments
;; The end result should depend on nothing but itself.
`(#:allowed-references ("out")
#:modules ((guix build utils))
#:builder
- (let ()
+ (let ((version ,(version-major+minor (package-version static-guile))))
(use-modules (guix build utils))
(let* ((in (assoc-ref %build-inputs "guile"))
(out (assoc-ref %outputs "out"))
(guile1 (string-append in "/bin/guile"))
(guile2 (string-append out "/bin/guile")))
- (mkdir-p (string-append out "/share/guile/2.0"))
- (copy-recursively (string-append in "/share/guile/2.0")
- (string-append out "/share/guile/2.0"))
+ (mkdir-p (string-append out "/share/guile/" version))
+ (copy-recursively (string-append in "/share/guile/" version)
+ (string-append out "/share/guile/" version))
- (mkdir-p (string-append out "/lib/guile/2.0/ccache"))
- (copy-recursively (string-append in "/lib/guile/2.0/ccache")
- (string-append out "/lib/guile/2.0/ccache"))
+ (mkdir-p (string-append out "/lib/guile/" version "/ccache"))
+ (copy-recursively (string-append in "/lib/guile/" version "/ccache")
+ (string-append out "/lib/guile/" version "/ccache"))
(mkdir (string-append out "/bin"))
(copy-file guile1 guile2)
@@ -789,10 +789,14 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
'((invoke guile2 "--version")))
#t))))
- (inputs `(("guile" ,%guile-static)))
+ (inputs `(("guile" ,static-guile)))
(outputs '("out"))
(synopsis "Minimal statically-linked and relocatable Guile")))
+(define %guile-static-stripped
+ ;; A stripped static Guile binary, for use during bootstrap.
+ (make-guile-static-stripped %guile-static))
+
(define (tarball-package pkg)
"Return a package containing a tarball of PKG."
(package (inherit pkg)