summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-04-15 18:14:24 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2020-04-20 08:00:18 +0200
commit2d49f175125cb83b3cffae89026404138f463aa3 (patch)
treee0a9ae9b7fee92c67d43804e5ca4535001799660
parenteaff60b35fed75c60d0db76c589e17d1500f60dd (diff)
downloadpatches-2d49f175125cb83b3cffae89026404138f463aa3.tar
patches-2d49f175125cb83b3cffae89026404138f463aa3.tar.gz
gnu: tls: Remove datefudge and disable tests on the Hurd.
* gnu/packages/tls.scm (gnutls)[arguments]: When compiling for the Hurd, disable tests. [native-inputs]: When compiling for the Hurd, do not include datefudge.
-rw-r--r--gnu/packages/tls.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 27d38ed258..c1bb7f6be0 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -181,7 +181,8 @@ living in the same process.")
"0jvca1qahn9lrwv6f5kfs95icirc15b2a8x9fzczyj996ipg3b5z"))))
(build-system gnu-build-system)
(arguments
- `(; Ensure we don't keep a reference to this buggy software.
+ `(,@(if (hurd-target?) '(#:tests? #f) '())
+ ; Ensure we don't keep a reference to this buggy software.
#:disallowed-references (,net-tools)
#:configure-flags
(list
@@ -230,7 +231,8 @@ living in the same process.")
`(("net-tools" ,net-tools)))
("pkg-config" ,pkg-config)
("which" ,which)
- ("datefudge" ,datefudge) ;tests rely on 'datefudge'
+ ,@(if (hurd-target?) '()
+ `(("datefudge" ,datefudge))) ;tests rely on 'datefudge'
("util-linux" ,util-linux))) ;one test needs 'setsid'
(inputs
`(("guile" ,guile-3.0)))