summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2020-04-14 11:06:07 -0400
committerKei Kebreau <kkebreau@posteo.net>2020-04-18 16:51:31 -0400
commit123e429e4ca29c385e5ea0ff13b1685de081bbd4 (patch)
tree6daceb3ad67e8bd2a9ba2fd7857a2715f2d4d4be
parent5b4ebb42dc6b8fa9d8e9e79b63977a5d344628b5 (diff)
downloadpatches-123e429e4ca29c385e5ea0ff13b1685de081bbd4.tar
patches-123e429e4ca29c385e5ea0ff13b1685de081bbd4.tar.gz
gnu: libical: Enable introspection and Vala bindings.
* gnu/packages/calendar.scm (libical)[arguments]: Enable introspection and Vala bindings. [native-inputs]: Add gobject-introspection and vala. (cherry picked from commit 1538791f2003620ff3436cba316a594931a5ab72)
-rw-r--r--gnu/packages/calendar.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index bd47800d1d..5132a9d8ab 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -38,6 +38,7 @@
#:use-module (gnu packages dav)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages perl)
@@ -136,7 +137,10 @@ the <tz.h> library for handling time zones and leap seconds.")
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; test suite appears broken
- #:configure-flags '("-DSHARED_ONLY=true")
+ #:configure-flags '("-DSHARED_ONLY=true"
+ ;; required by evolution-data-server
+ "-DGOBJECT_INTROSPECTION=true"
+ "-DICAL_GLIB_VAPI=true")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-paths
@@ -153,9 +157,11 @@ the <tz.h> library for handling time zones and leap seconds.")
(("\\\"/usr/share/lib/zoneinfo\\\"") "")))
#t)))))
(native-inputs
- `(("gtk-doc" ,gtk-doc)
+ `(("gobject-introspection" ,gobject-introspection)
+ ("gtk-doc" ,gtk-doc)
("perl" ,perl)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
(inputs
`(("glib" ,glib)
("libxml2" ,libxml2)