summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-05-07 09:58:56 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-05-07 09:58:56 +0200
commite5f1f5ce07f0976241ed1a68b952b40876eeafba (patch)
treefbbdb780a0bb4833c3efb1fd8b143541ecd4c1d8
parent3078c05eb2b514593ee34049eda49111ccbc3106 (diff)
downloadpatches-e5f1f5ce07f0976241ed1a68b952b40876eeafba.tar
patches-e5f1f5ce07f0976241ed1a68b952b40876eeafba.tar.gz
gnu: warsow-qfusion: Remove bundled binaries and inputs.
* gnu/packages/game-development.scm (warsow-qfusion)[source]: Add snippet to remove unused bundled binaries and inputs.
-rw-r--r--gnu/packages/game-development.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 05cc152afd..c63aac082a 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2246,7 +2246,13 @@ utilities frequently used in roguelikes.")
(base32
"0xv2yycr43p3xmq7lm6j6zb3cpcr6w00x7qg918faq0mw9j7v48g"))
;; Issue reported here: https://github.com/Warsow/qfusion/issues/46
- (patches (search-patches "warsow-qfusion-fix-bool-return-type.patch"))))
+ (patches (search-patches "warsow-qfusion-fix-bool-return-type.patch"))
+ (modules '((guix build utils)))
+ (snippet '(begin
+ (delete-file-recursively "platforms")
+ (delete-file-recursively "debian")
+ (delete-file-recursively "libsrcs")
+ #t))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; No tests.