summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-05-06 16:10:39 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-05-06 18:15:58 +0200
commitc75e349467a943a42974abcd107a25a90facd046 (patch)
tree1f4654e09d03b090e992e9b8447843b864379ff8
parent36ceab7da0f5c9dda9e93536819552f0fb13c596 (diff)
downloadpatches-c75e349467a943a42974abcd107a25a90facd046.tar
patches-c75e349467a943a42974abcd107a25a90facd046.tar.gz
gnu: sbcl-trivial-features: Update to 20200403.
* gnu/packages/lisp-xyz.scm (sbcl-trivial-features): Update to 20200403.
-rw-r--r--gnu/packages/lisp-xyz.scm38
1 files changed, 20 insertions, 18 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 7a8f68d8a6..4ca1c88f86 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -1157,25 +1157,27 @@ utilities that make it even easier to manipulate text in Common Lisp. It has
(sbcl-package->ecl-package sbcl-cl-strings))
(define-public sbcl-trivial-features
- (package
- (name "sbcl-trivial-features")
- (version "0.8")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/trivial-features/trivial-features.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name "trivial-features" version))
- (sha256
- (base32 "0ccv7dqyrk55xga78i5vzlic7mdwp28in3g1a8fqhlk6626scsq9"))))
- (build-system asdf-build-system/sbcl)
- (arguments '(#:tests? #f))
- (home-page "https://cliki.net/trivial-features")
- (synopsis "Ensures consistency of @code{*FEATURES*} in Common Lisp")
- (description "Trivial-features ensures that @code{*FEATURES*} is
+ ;; No release since 2014.
+ (let ((commit "870d03de0ed44067963350936856e17ee725153e"))
+ (package
+ (name "sbcl-trivial-features")
+ (version (git-version "0.8" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/trivial-features/trivial-features.git")
+ (commit commit)))
+ (file-name (git-file-name "trivial-features" version))
+ (sha256
+ (base32 "14pcahr8r2j3idhyy216zyw8jnj1dnrx0qbkkbdqkvwzign1ah4j"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments '(#:tests? #f))
+ (home-page "https://cliki.net/trivial-features")
+ (synopsis "Ensures consistency of @code{*FEATURES*} in Common Lisp")
+ (description "Trivial-features ensures that @code{*FEATURES*} is
consistent across multiple Common Lisp implementations.")
- (license license:expat)))
+ (license license:expat))))
(define-public cl-trivial-features
(sbcl-package->cl-source-package sbcl-trivial-features))