summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-12-23 10:24:45 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-08 23:51:03 +0100
commitaa372292b35264d4b3d7758b367aa25e34b23a85 (patch)
tree609e94ae35971f3f0b01b3d275bc035ea251809f
parent4b6456ce3baf663d719e65f4e7b65fbfaa1faabd (diff)
downloadpatches-aa372292b35264d4b3d7758b367aa25e34b23a85.tar
patches-aa372292b35264d4b3d7758b367aa25e34b23a85.tar.gz
gnu: cpulimit: Don't use unstable tarball.
* gnu/packages/admin.scm (cpulimit)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/admin.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index b3b4dc6d42..6aebe657ae 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1705,13 +1705,13 @@ lookup to YAML Mode. You could enable the mode with @code{(add-hook
(version "0.2")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/opsengine/cpulimit/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/opsengine/cpulimit.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "1nn2w849xd5bw4y5sqnll29nxdwl5h0cv4smc7dwmpb9qnd2ycb4"))))
+ (base32 "1dz045yhcsw1rdamzpz4bk8mw888in7fyqk1q1b3m1yk4pd1ahkh"))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases