summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-12-23 10:23:18 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-08 23:51:04 +0100
commit9bc96d13ce726ef91603459dfb023d65418ad7ad (patch)
tree8290495933738768f7fad66b8421e79990c103c3
parentaa372292b35264d4b3d7758b367aa25e34b23a85 (diff)
downloadpatches-9bc96d13ce726ef91603459dfb023d65418ad7ad.tar
patches-9bc96d13ce726ef91603459dfb023d65418ad7ad.tar.gz
gnu: fdupes: Don't use unstable tarball.
* gnu/packages/admin.scm (fdupes)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/admin.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 6aebe657ae..2b60e9136a 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1541,14 +1541,13 @@ degradation and failure.")
(version "1.6.1")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/adrianlopezroche/fdupes/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/adrianlopezroche/fdupes.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "1sj9pa40pbz6xdwbxfwhdhkvhdf1xc5gvggk9mdq26c41gdnyswx"))))
+ (base32 "19b6vqblddaw8ccw4sn0qsqzbswlhrz8ia6n4m3hymvcxn8skpz9"))))
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases