summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosh Marshall <joshua.r.marshall.1991@gmail.com>2020-05-03 18:22:23 -0400
committerMarius Bakke <mbakke@fastmail.com>2020-05-05 20:09:39 +0200
commit8b27771b77f024e47b0e12a4da54e4b0dd9fc830 (patch)
tree994c6c53d823e8be81a4e6dbef1e3749b2351b6f
parent51ac5ce4b509fac151e646deaff41a527270a74f (diff)
downloadpatches-8b27771b77f024e47b0e12a4da54e4b0dd9fc830.tar
patches-8b27771b77f024e47b0e12a4da54e4b0dd9fc830.tar.gz
gnu: Add python-pytest-asyncio.
* gnu/packages/check.scm (python-pytest-asyncio): New public variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 427607e6de..213363f645 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2019 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2020 Josh Marshall <joshua.r.marshall.1991@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1408,6 +1409,30 @@ executed.")
(define-public python2-coverage
(package-with-python2 python-coverage))
+(define-public python-pytest-asyncio
+ (package
+ (name "python-pytest-asyncio")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-asyncio" version))
+ (sha256
+ (base32 "1bysy4nii13bm7h345wxf8fxcjhab7l374pqdv7vwv3izl053b4z"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-async-generator" ,python-async-generator)
+ ("python-hypothesis" ,python-hypothesis)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/pytest-dev/pytest-asyncio")
+ (synopsis "Pytest support for asyncio")
+ (description "Python asyncio code is usually written in the form of
+coroutines, which makes it slightly more difficult to test using normal
+testing tools. @code{pytest-asyncio} provides useful fixtures and markers
+to make testing async code easier.")
+ (license license:asl2.0)))
+
(define-public python-cov-core
(package
(name "python-cov-core")