summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2020-05-01 12:00:21 +0200
committerBrice Waegeneire <brice@waegenei.re>2020-05-07 11:26:38 +0200
commit741d22264734b3c85ef10b47f6a39a474a736070 (patch)
treec8ed0bcfe931afe0b9cfa68105f90219511fe524
parenta87c90862cbe5f6406758add6e34e0a6a1aab1f4 (diff)
downloadpatches-741d22264734b3c85ef10b47f6a39a474a736070.tar
patches-741d22264734b3c85ef10b47f6a39a474a736070.tar.gz
gnu: Add pegtl.
* gnu/packages/cpp.scm (pegtl): New variable.
-rw-r--r--gnu/packages/cpp.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 2248ebfc4b..371927e4c6 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2020 Roel Janssen <roel@gnu.org>
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -485,3 +486,24 @@ point and then, after each tween step, plugging back the result.")
augment the C++ standard library. The Abseil library code is collected from
Google's C++ code base.")
(license license:asl2.0)))
+
+(define-public pegtl
+ (package
+ (name "pegtl")
+ (version "2.8.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/taocpp/PEGTL.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17crgjfdx55imi2dqnz6xpvsxq07390yfgkz5nd2g77ydkvq9db3"))))
+ (build-system cmake-build-system)
+ (home-page "https://github.com/taocpp/PEGTL")
+ (synopsis "Parsing Expression Grammar template library")
+ (description "The Parsing Expression Grammar Template Library (PEGTL) is
+a zero-dependency C++ header-only parser combinator library for creating
+parsers according to a Parsing Expression Grammar (PEG).")
+ (license license:expat)))