summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-05-06 13:41:08 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-05-06 18:15:57 +0200
commit53c4a0da0931a2a69ace6efced99e6eec730a5bc (patch)
tree5352bd80438681c1e2b35ef6100afe83f311ec09
parent426adb4fc50cdfbc29fdc6ab6654956d0bc9f5c8 (diff)
downloadpatches-53c4a0da0931a2a69ace6efced99e6eec730a5bc.tar
patches-53c4a0da0931a2a69ace6efced99e6eec730a5bc.tar.gz
gnu: sbcl-iolib: Update to 20200425.
* gnu/packages/lisp-xyz.scm (sbcl-iolib): Update to 20200425.
-rw-r--r--gnu/packages/lisp-xyz.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 47cf04b2c1..3059aaea0d 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5407,12 +5407,12 @@ formats.")
(define-public sbcl-iolib.asdf
;; Latest release is from June 2017.
- (let ((commit "81e20614c0d27f9605bf9766214e236fd31b99b4")
- (revision "1"))
+ (let ((commit "7f5ea3a8457a29d224b24653c2b3657fb1898021")
+ (revision "2"))
(package
(name "sbcl-iolib.asdf")
(build-system asdf-build-system/sbcl)
- (version "0.8.3")
+ (version (git-version "0.8.3" revision commit))
(home-page "https://github.com/sionescu/iolib")
(source
(origin
@@ -5423,7 +5423,7 @@ formats.")
(file-name (git-file-name name version))
(sha256
(base32
- "1j81r0wm7nfbwl991f26s4npcy7kybzybd3m47rbxy31h0cfcmdm"))))
+ "1bg5w7lm61hqk4b0svmri8a590q36z76jfa0sdgzb39r98c04w12"))))
(inputs
`(("alexandria" ,sbcl-alexandria)))
(arguments
@@ -5498,7 +5498,7 @@ and @code{kqueue(2)}), a pathname library and file-system utilities.")
(inputs
`(("iolib.asdf" ,sbcl-iolib.asdf)
("iolib.conf" ,sbcl-iolib.conf)
- ("iolib.grovel" ,sbcl-iolib.grovel)
+ ("cffi-grovel" ,sbcl-cffi-grovel)
("iolib.base" ,sbcl-iolib.base)
("bordeaux-threads" ,sbcl-bordeaux-threads)
("idna" ,sbcl-idna)
@@ -5510,7 +5510,6 @@ and @code{kqueue(2)}), a pathname library and file-system utilities.")
(arguments
'(#:asd-file "iolib.asd"
#:asd-system-name "iolib/syscalls"
- #:test-asd-file "iolib.tests.asd"
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-paths
@@ -5521,7 +5520,7 @@ and @code{kqueue(2)}), a pathname library and file-system utilities.")
"(:default \""
(assoc-ref inputs "libfixposix") "/lib/libfixposix\")")))
;; Socket tests need Internet access, disable them.
- (substitute* "iolib.tests.asd"
+ (substitute* "iolib.asd"
(("\\(:file \"sockets\" :depends-on \\(\"pkgdcl\" \"defsuites\"\\)\\)")
"")))))))
(synopsis "Common Lisp I/O library")))
@@ -5537,8 +5536,6 @@ and @code{kqueue(2)}), a pathname library and file-system utilities.")
(substitute-keyword-arguments (package-arguments sbcl-iolib+syscalls)
((#:asd-system-name _) "iolib/multiplex")))))
-
-
(define sbcl-iolib+streams
(package
(inherit sbcl-iolib+syscalls)