summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-12-23 10:20:23 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-08 23:51:02 +0100
commit4b6456ce3baf663d719e65f4e7b65fbfaa1faabd (patch)
tree6d530dd33279b18db6773d589b85d280241e452a
parentfc204d24be83a9b822145f3a232491f52304a5b5 (diff)
downloadpatches-4b6456ce3baf663d719e65f4e7b65fbfaa1faabd.tar
patches-4b6456ce3baf663d719e65f4e7b65fbfaa1faabd.tar.gz
gnu: progress: Don't use unstable tarball.
* gnu/packages/admin.scm (progress)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/admin.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index ebc893608a..b3b4dc6d42 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -148,13 +148,15 @@ usual file attributes can be checked for inconsistencies.")
(package
(name "progress")
(version "0.14")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/Xfennec/"
- name "/archive/v" version ".tar.gz"))
- (sha256
- (base32 "1wcanixfsi5k4i9h5vrnncgjdncalsdfqllrxibxwpgfnf20sji1"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Xfennec/progress.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1lk2v4b767klib93an4g3f7z5qrv9kdk9jf7545vw1immc4kamrl"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -162,12 +164,12 @@ usual file attributes can be checked for inconsistencies.")
(inputs
`(("ncurses" ,ncurses)))
(arguments
- `(#:tests? #f ; There is no test suite.
+ `(#:tests? #f ; no test suite
#:make-flags (list "CC=gcc"
(string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
- (delete 'configure)))) ; There's no configure phase.
+ (delete 'configure)))) ; no configure script
(home-page "https://github.com/Xfennec/progress")
(synopsis "Program to view the progress of the coreutils commands")
(description "A program that looks for coreutils basic commands (cp, mv,