summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVijayalakshmi Vedantham <vijimay12@gmail.com>2018-03-19 00:39:05 +0530
committerRicardo Wurmus <rekado@elephly.net>2018-03-19 01:06:41 +0100
commit109b2f7c93f15a3ee9eb705584c384dcf13862f4 (patch)
tree21f7501d25110941883ef81c8715a61e0d3ab06a
parent71e08fde28fa335bdba2ec2150fd6663390bba5a (diff)
downloadpatches-109b2f7c93f15a3ee9eb705584c384dcf13862f4.tar
patches-109b2f7c93f15a3ee9eb705584c384dcf13862f4.tar.gz
gnu: Add r-abbyyr.
* gnu/packages/cran.scm (r-abbyyr): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 717fa7fdfa..b54ddc6b55 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Raoul Bonnal <ilpuccio.febo@gmail.com>
+;;; Copyright © 2018 Vijayalakshmi Vedantham <vijimay12@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -59,6 +60,36 @@ diversification and macroevolution, computing distances from DNA sequences,
and several other tools.")
(license license:gpl2+)))
+(define-public r-abbyyr
+ (package
+ (name "r-abbyyr")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "abbyyR" version))
+ (sha256
+ (base32
+ "1s8zf18sh0s89vk3dl09fzrq50csmmfvmsanf5vfkv9n5lx6pklg"))))
+ (properties `((upstream-name . "abbyyR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-curl" ,r-curl)
+ ("r-httr" ,r-httr)
+ ("r-plyr" ,r-plyr)
+ ("r-progress" ,r-progress)
+ ("r-readr" ,r-readr)
+ ("r-xml" ,r-xml)))
+ (home-page "https://github.com/soodoku/abbyyR")
+ (synopsis "Access to Abbyy Optical Character Recognition (OCR) API")
+ (description
+ "This package provides tools to get text from images of text using Abbyy
+Cloud Optical Character Recognition (OCR) API. With abbyyyR, one can easily
+OCR images, barcodes, forms, documents with machine readable zones, e.g.
+passports and get the results in a variety of formats including plain text and
+XML. To learn more about the Abbyy OCR API, see @url{http://ocrsdk.com/}.")
+ (license license:expat)))
+
(define-public r-colorspace
(package
(name "r-colorspace")